WLAN Geräte finden LAN Geräte nicht - Heimnetzgruppe nicht sichtbar

Für alle Technik-Themen bezogen auf Internet und Telefonie, die weder AVM- noch Hitron-/Compal-/Technicolor-/Sagemcom-/Arris-Produkte betreffen. Speedprobleme werden hier lediglich thematisiert, wenn sie auf die verwendeten Geräte zurückzuführen sind (die nicht zu den o.g. Produkten zählen).
Forumsregeln
Forenregeln
oldmanpetterson
Fortgeschrittener
Beiträge: 104
Registriert: 10.01.2016, 18:57

Re: WLAN Geräte finden LAN Geräte nicht - Heimnetzgruppe nicht sichtbar

Beitrag von oldmanpetterson » 01.01.2019, 17:09

ok; keine Routen eingerichtet.
Das heisst was genau?

Wenn ich meine Firewall etc. deaktiviere, dann finde ich trotzdem nichts im Netzwerk.

Flole
Kabelfreak
Beiträge: 1443
Registriert: 31.12.2015, 01:11

Re: WLAN Geräte finden LAN Geräte nicht - Heimnetzgruppe nicht sichtbar

Beitrag von Flole » 01.01.2019, 17:55

Die Firewall im Orbi, und die kannst du beim Routing nicht deaktivieren (und es muss dann ne statische Route für das Orbi Netz eingerichtet werden).

oldmanpetterson
Fortgeschrittener
Beiträge: 104
Registriert: 10.01.2016, 18:57

Re: WLAN Geräte finden LAN Geräte nicht - Heimnetzgruppe nicht sichtbar

Beitrag von oldmanpetterson » 01.01.2019, 18:21

ok ich bin gewillt dieses zu tun.
aber kannst du das nochmal ganz kurz in 1 oder 2 sätzen genauer erläutern? :grin:

reneromann
Insider
Beiträge: 4277
Registriert: 28.06.2015, 13:26

Re: WLAN Geräte finden LAN Geräte nicht - Heimnetzgruppe nicht sichtbar

Beitrag von reneromann » 01.01.2019, 18:45

Flole hat geschrieben:
01.01.2019, 17:55
Die Firewall im Orbi, und die kannst du beim Routing nicht deaktivieren (und es muss dann ne statische Route für das Orbi Netz eingerichtet werden).
Nochmal: Es muss KEINE statische Route gesetzt werden, weil der Orbi im Router-Modus NAT betreibt.
Und auch wenn ich mich wiederhole: Der Laptop kommt doch laut Aussage vom TE per Browser auf's WebInterface des NAS/Servers - damit passen die Routen, was auch kein Wunder ist, weil der Server/das NAS nur die "WAN"-IP des Orbi (aufgrund des NAT) sieht. Deshalb braucht es auch keine statischen Routen - denn der WAN-Port des Orbi ist ja im gleichen Subnetz wie das NAS/Server.

Das Problem ist alleine die Firewall, die hier anscheinend SMB- und NETBIOS nicht durch lässt (um zumindest vom Laptop im WLAN auf die LAN-Geräte zuzugreifen).
In Gegenrichtung ist das Problem dann neben der Firewall natürlich das doppelte NAT...

Daher meine DRINGENDE Empfehlung, sofern überhaupt möglich:
Stell den Orbi in den Accesspoint-Modus um - dann hast du die ganzen Probleme nicht.

Wenn das nicht geht: Hol dir einen AccessPoint!

Flole
Kabelfreak
Beiträge: 1443
Registriert: 31.12.2015, 01:11

Re: WLAN Geräte finden LAN Geräte nicht - Heimnetzgruppe nicht sichtbar

Beitrag von Flole » 01.01.2019, 18:47

reneromann hat geschrieben:
01.01.2019, 18:45
Flole hat geschrieben:
01.01.2019, 17:55
Die Firewall im Orbi, und die kannst du beim Routing nicht deaktivieren (und es muss dann ne statische Route für das Orbi Netz eingerichtet werden).
Nochmal: Es muss KEINE statische Route gesetzt werden, weil der Orbi im Router-Modus NAT betreibt.
Aber wie soll vor Orbi (also LAN) dann auch nach WLAN kommunizieren? Dafür braucht es schon ne statische Route, egal ob da irgendwer NAT macht oder nicht....

reneromann
Insider
Beiträge: 4277
Registriert: 28.06.2015, 13:26

Re: WLAN Geräte finden LAN Geräte nicht - Heimnetzgruppe nicht sichtbar

Beitrag von reneromann » 01.01.2019, 19:03

Flole hat geschrieben:
01.01.2019, 18:47
reneromann hat geschrieben:
01.01.2019, 18:45
Flole hat geschrieben:
01.01.2019, 17:55
Die Firewall im Orbi, und die kannst du beim Routing nicht deaktivieren (und es muss dann ne statische Route für das Orbi Netz eingerichtet werden).
Nochmal: Es muss KEINE statische Route gesetzt werden, weil der Orbi im Router-Modus NAT betreibt.
Aber wie soll vor Orbi (also LAN) dann auch nach WLAN kommunizieren? Dafür braucht es schon ne statische Route, egal ob da irgendwer NAT macht oder nicht....
Eben nicht - wenn NAT gemacht wird, siehst du im LAN KEINE der im WLAN benutzten Adressen - da hilft dir dann auch KEINE statische Route (mehr). Im LAN siehst du dann aufgrund des NAT ausschließlich die WAN-seitige IP des Orbi, denn das NAT täuscht ja gerade vor, dass sich hinter der IP nur genau EIN Gerät befindet (und kein ganzes Subnetz mehr). Alle WLAN-Geräte sind im LAN aufgrund des NAT daher zu nur einer einzigen IP (nämlich der WAN-seitigen IP des Orbi, die dann eine IP im LAN-Subnetz ist) zusammengefasst. Damit ist auch aufgrund des NAT von LAN-Netz aus auch KEIN Zugriff mehr auf dedizierte Geräte innerhalb des WLAN möglich - du kommst bis zum Orbi (der NAT macht) und das war's dann.

Statische Routen würde man nur dann benötigen, wenn der Orbi KEIN NAT machen würde - nur wenn man dem das NATten abgewöhnen kann, dann sollte man gleich eine Nummer weiter gehen und ihn zu einem "dummen" Accesspoint machen.
Übrigens müsste eine statische Route in dem Fall auch "nur" im vorgelagerten Router (wahrscheinlich eine FritzBox) eingetragen werden.

Flole
Kabelfreak
Beiträge: 1443
Registriert: 31.12.2015, 01:11

Re: WLAN Geräte finden LAN Geräte nicht - Heimnetzgruppe nicht sichtbar

Beitrag von Flole » 01.01.2019, 19:07

Wenn du es in der Firewall erlaubst kommst du durch den Orbi durch, das Nat sagt nichts darüber aus das Geräte hinter dem Router nicht erreichbar sein können. Meine Fritzboxen und Modems sind vor der Firewall die NAT macht, und die können jedes einzelne Gerät im Netzwerk erreichen (was die Firewall erlaubt).

reneromann
Insider
Beiträge: 4277
Registriert: 28.06.2015, 13:26

Re: WLAN Geräte finden LAN Geräte nicht - Heimnetzgruppe nicht sichtbar

Beitrag von reneromann » 01.01.2019, 19:26

Flole hat geschrieben:
01.01.2019, 19:07
Wenn du es in der Firewall erlaubst kommst du durch den Orbi durch, das Nat sagt nichts darüber aus das Geräte hinter dem Router nicht erreichbar sein können.
Bei NAT findet eine Adressübersetzung statt - soweit sind wir uns wohl einig.
Wenn der Orbi beim sNAT (klassischerweise, wie es alle "normalen" Consumer-Router machen) ALLE internen Adressen auf nur EINE externe Adresse ummünzt, dann ist von außen (also hier dem LAN) KEIN Zugriff auf die WLAN-Endgeräte mehr möglich, AUSSER man erstellt entsprechende Forwarding-Regeln im NAT. Denn woher soll der Orbi (ohne solche Regeln) beim NAT wissen, an welches interne (WLAN-)Endgerät er den vom externen (LAN-)Endgerät kommenden Request auf z.B. Port 445/TCP weiterleiten soll? Richtig - er kann es nicht wissen und daher sind die verschiedenen WLAN-Geräte NICHT aus dem LAN eben NICHT erreichbar. Mit der Firewall selbst hat das erst einmal noch gar nichts zu tun - die kommt dann zusätzlich noch als Problem oben drauf!

Etwas anderes ist es, wenn du HINTER dem NAT (also im Fall des Orbi im WLAN) sitzt - dann kannst du natürlich auf alle LAN-Geräte zugreifen - hier weiß das NAT ja, von welchem internen (WLAN-)Endgerät der Request auf welches externe (LAN-)Endgerät geht. Dafür braucht es aber KEINE statischen Routen, welche eben im externen (LAN-)Netz nur genau EINE IP-Adresse für ALLE internen (WLAN-)Geräte auftitt: Die des Orbi, der NAT macht.
Selbst wenn du an den Orbi aus dem LAN jetzt Pakete mit einer bestimmten internen IP des WLAN-Netzes senden würdest, würde er diese verwerfen, weil er eben KEIN klassischer Router, sondern ein NAT-Gateway ist.
Meine Fritzboxen und Modems sind vor der Firewall die NAT macht, und die können jedes einzelne Gerät im Netzwerk erreichen (was die Firewall erlaubt).
Ich glaube du verwechselst hier die Richtung des Zugriffs: Wenn du von einem Gerät in deinem Netzwerk die Verbindung zur FritzBox (z.B. zum WebIF) initiierst, gibt es gar keine Probleme mit den NAT.
Nur anders herum wird deine FritzBox eben am NAT scheitern - sprich wenn die FritzBox eine Verbindung zu einem bestimmten Gerät HINTER dem NAT aufbauen will, müsste sie dieses Gerät einzeln adressieren können - bei "klassischem" NAT auf der Firewall (sofern nicht 1:1-NAT von einem extrenen IPv4-Subnetz auf ein internes IPv4-Subnetz durchgeführt wird, was aber bei Consumer-Routern in der Regel so nicht implementiert ist) kann sie das aber nicht, weil eben alle Geräte im internen Netz (hinter dem NAT) mit nur einer IP an sie herantreten. Das was du mit "was die Firewall erlaubt" wahrscheinlich eher meinst, sind Portfreigaben - und selbst dann kann die Fritte nur genau das eine Gerät erreichen, welches durch die Firewall die weitergeleiteten Pakete empfängt.

Benutzeravatar
Besserwisser
Insider
Beiträge: 4015
Registriert: 01.08.2010, 16:15
Wohnort: zu Hause

Re: WLAN Geräte finden LAN Geräte nicht - Heimnetzgruppe nicht sichtbar

Beitrag von Besserwisser » 01.01.2019, 19:32

Wenn der Orbi im LAN als Router hinter der Fritzbox arbeitet,
muß dann nicht auch ein Gateway im Orbi eingetragen sein?

reneromann
Insider
Beiträge: 4277
Registriert: 28.06.2015, 13:26

Re: WLAN Geräte finden LAN Geräte nicht - Heimnetzgruppe nicht sichtbar

Beitrag von reneromann » 01.01.2019, 19:39

Besserwisser hat geschrieben:
01.01.2019, 19:32
Wenn der Orbi im LAN als Router hinter der Fritzbox arbeitet,
muß dann nicht auch ein Gateway im Orbi eingetragen sein?
Wenn der Orbi DHCP auf WAN-Seite macht, dann bekommt er das Gateway wie seine IP-Adresse ganz normal per DHCP zugeteilt...
Wenn kein Gateway eingetragen wäre (oder er keines per DHCP bekommen würde), würde der Zugriff auf's Internet nicht klappen ;-)